Problem:
- I have an Assignee with the label ‘Unlicensed’
- I expect certain users to be added as Assignee via the Assignee Rules / Dynamic Assignees, but they aren't
- I get a message that I have run out of licenses for my users
Answer:
Check your license use, and add Assignees in another way if there are sufficient licenses available. If you are short on licenses, free up licenses or obtain more.
Check your current license use
First, have a look at your current license status and who is using them.
- In Plauti Assign > Setup and Status > Licensing Status you can check the number of licenses that are in use out of the total number of available licenses.
- In Salesforce Setup > Installed Packages > Plauti Assign > Manage Licenses you can check which users currently have a Plauti Assign license.
If you have sufficient licenses available
If you have freed up licenses in the mean time, these can be applied manually or with the Assignee Rules / Dynamic Assignees.
- Assignees with the label ‘Unlicensed’ need to be deleted first. Go to tab Assignee Summary, open the Assignee, and click Delete.
- Add one or more Assignees via their intended Match Group: on the Match Group, go to subtab Assignees, and click Add.
Read more in Assignees. - To add a group of users as Assignees to the same Match Group, you can also add them as Dynamic Assignees. On the Match Group, go to subtab Dynamic Assignees. Set up Assignee Rules or apply existing ones. This way they will also be removed from the Match Group again if they no longer adhere to the Assignee Rules (for example if they switched teams), ensuring they are not holding a license unneeded.
- Alternatively you can allocate licenses via Salesforce Setup: go to Salesforce Setup > Installed Packages > Plauti Assign > Manage Licenses and click Add Users.
If you ran out of licenses
First check if you happen to have any Assignees that should not be there anymore, for example inactive assignees that left the team. Remove such assignees from the Match Groups to free up licenses. Note that licenses are issued per user, so you will need to remove all Assignees that are related to a certain user in order to free up that user's license.
Then proceed above under ‘If you have sufficient licenses available’.
If you cannot free up any more licenses, then you will need to purchase more; this can be done by amending your Plauti Assign subscription. See here for more details.
If you have any questions about this, feel free to contact Plauti Support at Plauti.com/Contact.
Cause of the problem
So how could this problem occur?
Usually it's simply a case of running out of licenses.
In the case of Assignees being labeled as ‘Unlicensed’: Plauti Assign allocates licenses when Assignees are added, but cannot do so if licenses have been maxed out. When users are added via Assignee Rules / Dynamic Assignees, nowadays they cannot be added when there are no licences available, but in the past they were added without a license. This might be a remnant of that.
Alternatively, an administrator might have removed a user's license from the 'Manage Licenses' section in Salesforce Setup.